Benchmark

Software für CP/M, die nicht Teil des Betriebssystems ist
Antworten
Benutzeravatar
Alfred
Beiträge: 278
Registriert: 17. Jun 2019, 18:47
Wohnort: Enzkreis

Benchmark

Beitrag von Alfred » 7. Dez 2023, 18:39

Hallo zusammen,

den ASCII Benchmark für Microsoft MBASIC v5.21 gibt es z.B. hier:
https://www.retrobrewcomputers.org/doku ... 80_mark_iv

Das Ergebnis sieht so aus:
MBROT.JPG
MBROT.JPG (148.43 KiB) 6910 mal betrachtet
Laufzeit mit Z80B 6-Mhz, 19200Bd und CP/M 1.4 = 3 Min. 10 Sek.

Gruß
Alfred
Dateianhänge
MBROT.BAS.zip
(340 Bytes) Noch nie heruntergeladen

SolderGirl
Beiträge: 8
Registriert: 20. Mai 2024, 17:56

Re: Benchmark

Beitrag von SolderGirl » 20. Mai 2024, 19:06

Soeben getested mit MBASIC 5.29
MBROT.PNG
MBROT.PNG (42.79 KiB) 4931 mal betrachtet
Laufzeit auf einem 10MHz Z80, 57600 bps und Z3Plus: 2 Min. 4 Sek.

Benutzeravatar
Alfred
Beiträge: 278
Registriert: 17. Jun 2019, 18:47
Wohnort: Enzkreis

Re: Benchmark

Beitrag von Alfred » 21. Mai 2024, 11:13

Sauber, das Verhältnis bzw. Ergebnis 6/10 MHz passt!
Muss ich gelegentlich mal auf dem Ct180 testen ...

PS: Herzlich willkommen im Forum :-)

Gruß
Alfred

Benutzeravatar
Alfred
Beiträge: 278
Registriert: 17. Jun 2019, 18:47
Wohnort: Enzkreis

Re: Benchmark

Beitrag von Alfred » 25. Mai 2024, 12:57

Der Ct180 (HD64180 CPU) mit 9,216 MHz, 19200Bd unter CP/M 3.1 schafft es in 1:55 :-)!

Werner_8085
Beiträge: 80
Registriert: 24. Jun 2019, 18:03
Wohnort: Rees
Kontaktdaten:

Re: Benchmark

Beitrag von Werner_8085 » 27. Mai 2024, 10:08

... der Prof180x (Ausstattung wie der Ct180 von Alfred) benötigt auch ca. 2min.
Der Unterschied zwischen MBASIC 521 und 529 geht in der Handmessung unter.

mein Moppel mit 3Mhz (NSC800) unter CP/M2.2 benötigt gute 7min auf der originalen CRT-Karte,
über ein 9600Bd Terminal sind es "nur" 6min.

Hier entfällt das leidige Umschalten auf Monitorebene und die Synchronisation mit der Bildaustastlücke - für jedes Zeichen...

LG Werner

SolderGirl
Beiträge: 8
Registriert: 20. Mai 2024, 17:56

Re: Benchmark

Beitrag von SolderGirl » 8. Jun 2024, 20:52

Ich habe mein eZ80 Board so weit das ich CP/M 3 booten kann.
Da ist noch irgendwo ein Bug im Treiber für die SD Karte, der dazu führt das längere Schreibvorgänge einen Absturz auslösen. Aber ich habe mal MBROT.BAS laufen lassen.
Auf dem eZ80 braucht es ca. 30 Sekunden.

Hier ein Vergleich zwischen dem 10 MHz Z80 und dem 36 MHz eZ80:


Antworten